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ABSTRACT 

The paper deals with the system Maple in mathematical 
modelling and computer simulation of technical or 
financial problems. It presents also possibilities of 
Maple for students in learning of mathematical 
modelling. There are presented some solved problems 
using Maple and introduced shortly developed 
modelling and simulation tool - MapleSim. 

 
INTRODUCTION 

Mathematical models used in scientific computing [1] 
are becoming large and the number of computations 
needed for simulation is increasing. Simultaneously 
there are growing requirements on model performance 
and accuracy. When simulation models are designed we 
encounter several problems that must be solved in order 
to achieve these goals. The system Maple is appropriate 
computer environment which enable to solve these 
goals. The main domains, where is possible to use 
Maple, are (see Fig. 1):

o Monte Carlo simulations 
o Data regressions 
o Probabilistic modelling and analysis 
o Economic research and modelling 
o Quantitative pricing and hedging models  
o Calibration  
o Stochastic modelling 
o Optimizations 

 

 
Figure 1: Modelling in system Maple 

Firstly, there are presented new possibilities of the 
Maple computer environment for mathematics, 
mathematical modelling and simulation in scientific 
computing. Users can access the power of the Maple 
computation engine through a variety of user interfaces: 
 

o the Standard Worksheet (contains the full-
featured interface), 

o the Command-Line version (it does not include 
graphical user interfaces features, but this 
method is recommended when solving very 
large complex problems or using scripts for 
batch processing), 

o the Classic Worksheet (on Windows and UNIX 
platforms provides a basic worksheet 
environment for older computers with limited 
memory), 

o custom-built Maplet applications (it allows to 
create windows, dialogs, and other visual 
interfaces that interact with a user to provide 
the power of Maple. Users can perform 
calculations or plot functions without using the 
Standard Worksheet interface. A Maplet  
application is a collection of elements 
including, but not limited to, windows and 
their associated layouts, dialogs, and actions, 
and 

o the Maplesoft(TM) Graphing Calculator (is a 
convenient calculator using Maple technology. 
It is available as part of Maple installation 
(Windows(R) only). 

 
Maple provides users with two worksheet interfaces. 
Both have access to the full mathematical engine of 
Maple and take advantage of the new functionality in 
Maple. By default, worksheets open in the enhanced and 
more modern Standard Worksheet. The Classic 
Worksheet, available on Windows and UNIX platforms, 
has the traditional Maple worksheet look and uses less 
memory. In Windows, user can change the Maple 
worksheet file association using the Worksheet File 
Association Selector application from the Tools folder 
of the Maple Start menu. If computer system has less 
than the recommended amount of physical memory, it is 
suggested that users use the Classic Worksheet version 
of Maple. For system requirements, refer to the Maple 
Web site http://www.maplesoft.com and search on 
current version of Maple (now Maple 11) and System 
Requirements. 
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Every user can create powerful interactive documents 
with Maple. The Maple environment allows a user to 
start solving problems right away by entering 
expressions in 2-D math and using simple point-and-
click interfaces to solve these expressions without 
having to know any commands. The users can combine 
text and mathematical expression in the same line, add 
tables to organize the content of their work, or insert 
images, sketch regions, and spreadsheets. They can 
visualize and animate problems in two and three 
dimensions, format text for academic papers, or books, 
and insert hyperlinks to other Maple files, Web sites, or 
email addresses. They can embed and program 
graphical user interface (GUI) components, as well as 
devise custom solutions using the Maple programming 
language. 

 
WORKING WITH MAPLE DOCUMENT MODE 
 
The first Maple session opens with the Startup dialog 
explaining the difference between Document mode and 
Worksheet mode. Using either mode, users can create 
high quality interactive mathematical documents. Each 
mode offers the same features and functionality, the 
only difference is the input region of each mode. 

o Document Mode - The default input region is a 
Document Block. Document Blocks hide 
Maple syntax allowing you to focus on the 
problem instead of the commands used to solve 
the problem. When using context menus in 
Document Mode, input and output are 
connected using an arrow or equal sign with 
self-documenting text indicating the 
calculation that had taken place. 

o Worksheet Mode - The default input region is a 
Maple input prompt >. Using the Maple 
prompt, all commands are displayed. 

 
Regardless of which mode users are working in, they 
have the opportunity to show or hide their calculations. 
Worksheet Mode and Document Mode are identical in 
the functionality that they both offer; therefore in each 
mode context menus and palettes are available when 
entering expressions; tables, spreadsheets, and images 
can be inserted; and access to the complete Maple 
library is available. Users can even insert a document 
block while in Worksheet mode or insert a Maple 
prompt while in Document Mode. The only difference 
between the two modes is the default input format. 
 

Table 1. Default input region in worksheet and 
document mode 

 
 
To start a Maple session in Document Mode, it is 
necessary to select from the File menu → New 
(showing Worksheet mode, document Mode, 
Templates…) → Document Mode. A blank document 
is displayed, see Fig. 2. 

 
 

Figure 2: Blank document in Maple Document Mode 
 

In subsequent sessions, is described how to us Maple 
Document Mode. Maple starts in Document mode. 
Every time you open a document, Maple displays a 
Quick Help pop-up list of important shortcut keys. To 
invoke Quick Help at any time, press the F1 key. 
In order to see a Document Block region, you need to 
display the Markers bar. The Markers bar is a vertical 
bar along the left pane, see Fig. 1. To display Markers, 
select View→ Markers. 
Maple users can even insert a document block in 
Document Mode, toggling between Text and Math 
modes switches between entering text and entering 2-D 
mathematical expressions. It is used the F5 key to 
switch between Math and Text modes. Math mode is 
characterized by a slanted, italic prompt (/) whereas the 
Text mode is characterized by a regular prompt (|). 
In Document mode, any Maple statement to evaluate 
must be entered in Math mode. In Document mode is 
used keys Ctrl+= to evaluate given mathematical 
expression or Maple command. 
In subsequent sessions, are described menu of 
Assistants, Tutors, Tasks and Pallets, which improve 
efficiency using Maple environment and simplify user 
work with using Maple. 
 
Assistants 

 
Maple offers a set of Assistants in the form of graphical 
user interfaces for easily interacting with Maple without 
the need of syntax of Maple. Using the menu, user can 
access by selecting Tools→Assistants to help you 
accomplish these various tasks, see Fig. 3. In some 
cases, users can launch the assistants by entering an 
expression and selecting the assistants from the context 
menu that displays. 
 

 
Figure 3: Assistants selection 



Tutors 
 
Over 40 interactive tutors that help beginner users gain 
insight and understanding of topics in precalculus, 
calculus, multivariate calculus, vector calculus, and 
linear algebra courses. Some tutors help users to work 
through a problem step-by-step. These tutors are easily 
accessible by selecting Tools → Tutors→ a subject of 
your choice → any tutor of your choice, see Fig. 4. 
 

 
Figure 4: Tutors selection 

 
Figures 5-7 show some examples of these tutors, 
concretely for Cross Sections, Curve Analysis and 
Approximate Integration. 

 

 
 

Figure 5: Tutor for Cross Sections 
   

   
 

Figure 6: Tutor for Curve Analysis 
 

 
 

Figure 7: Tutor for Approximate Integration 
 

Context menus 
 
A context-sensitive menu is a dynamically generated 
Maple menu of actions that are applicable for the region 
upon which it is invoked. Context menus allow users to 
perform calculations and manipulations on expressions 
without using Maple syntax. To display a context menu, 
users right-click (Control-click for) an object, 
expression, or region, see Fig. 8. 
Context menus are available for many input regions of 
document including: 

o expressions, to perform calculations, 
manipulations, or plotting, 

o plot regions, to apply plot options and 
manipulate the plot, 

o tables, to modify the table properties, 
o palette regions, to add or remove palettes and 

palette regions , 
o text regions, to add annotations and format 

text, 
o spreadsheets, to manipulate the spreadsheet. 
 

 
 

Figure  8: Context menu in Maple 12 Document Mode 
 



When performing calculations or manipulations on an 
expression, an arrow or equal sign connects the input 
and output, with text above the arrow or equal sign, 
indicating the action took place. 
New feature in Maple 12 in context menu is shown in 
Fig. 9 and 10. It is called Explore and allows to users to 
explore any Maple expression – here is explored 3D-
plot of function , where n,m are 
parameters which could be set up by build-in sliders. 

)sin( mn yx +

 

 
 

Figure 9: Explore - context menu in Maple 12 
 

 
Figure 10: Exploring 3D-plot of  )sin( mn yx +

 
Tasks 
 
Maple help users to perform specific tasks in Maple, 
such as: 

o Performing a mathematical computation; for 
example, solving an equation symbolically or 
numerically, or determining the Taylor 
approximation of a function of one variable, 

o Constructing a Maple object; for example, a 
function, 

o Creating a document; for example, an 
application. 

The tasks in Maple environment are organized in the 
Maple help system by subject, to help users find the 
appropriate task quickly. Each task is a collection of 

content, such as 2-D mathematics, commands, 
embedded components (for example, buttons) and plots 
that users can directly insert into their document. They 
specify the parameters of their problem, and then run 
the document. 
 

 
 

Figure 11: Task “Solve inequality” selection 
 

The Maple document environment provides access to 
over 20 palettes. Palettes are collections of related items 
that users can insert by clicking or drag-and-dropping 
into a document. 

 
Commands of Maple 
 
Maple is powerful, flexible, and customizable. In 
addition to the point-and-click features, Maple contains 
a set of commands and a programming language. 
Commands are contained in the Maple library, which is 
divided into two groups: the main library and packages. 

o The main library contains the most frequently 
used Maple commands. 

o Packages contain related commands for 
performing tasks from disciplines such as 
Student Calculus, Statistics, or General 
Relativity Theory. For example, the 
Optimization Package 

(Fig. 12) contains commands for numerically solving 
optimization problems.  
 

 
 

Figure 12: Help page of Optimization Package 
 

If users are familiar with Maple commands or they want 
to interact with Maple using commands, simply enter 



the command using 2-D math at an input prompt. The 
command names must display in italics. Maple 
commands are constructed in a format similar to 
command (arguments) based on the command they are 
using, see Fig. 13. 
 

 
 

Figure 13: Entering commands 
 

MAPLE TOOLBOXES 
 
Maple Professional Toolboxes greatly extend the scope 
and functionality of Maple for specialized application 
areas. Designed to work seamlessly with the core Maple 
product suite, these high-performance products deploy 
best of breed technology to deliver maximum benefit 
from the world's most powerful technical software 
platform. Toolboxes target key application areas in 
engineering and science, and technical application 
development.  The list of toolboxes is following:  

o Maple Financial Modelling Toolbox 
o Global Optimization Toolbox for Maple 
o Maple NAG Connector 
o Database Integration Toolbox for Maple 
o Maple Toolbox for Matlab 
o Grid Computing Toolbox for Maple 
o Maple Professional Math Toolbox for 

LabVIEW 
 
Financial modelling 
 
The Maple Financial Modelling Toolbox complements 
Maple’s multi-disciplinary environment with over 100 
new commands, designed specifically for quantitative 
financial modelling and analysis. These can be 
combined with the existing Maple tools - including 
ODE and PDE solvers, statistical data analysis and 
optimization, to produce analytical applications and 
product prototypes in the Maple interactive document 
interface. Common application fields for financial 
modelling are:  

o Risk analysis 
o Portfolio management 
o Quantitative analysis 
o Model validation/vetting 

Two examples are presented on next figures. First 
figure, it is part of Black-Scholes model (with local 
volatility) for some market data, see Fig. 14.  

 

 
 
Figure 14: Example of financial model (Black-Scholes) 
 
Second figure (Fig 15) shows a model of stock prices 
with estimation of their distribution in fixed time point. 

 

Figure 15: Example of financial model of stock prices 
 
THE FUTURE OF MAPLE MODELLING 
ENVIRONMENT - MAPLESIM 

 
There is introducing a new product that Maplesoft is 
working on called MapleSim, This product will address 
many problems that engineers are struggling with when 
using traditional mathematical modelling and simulation 
tools. By using extensive math solvers and 
simplification technologies, MapleSim will be able to 
produce highly concise models for efficient numeric 
computation. This will deliver much faster simulations 
than can be produced with traditional simulation 
software that needs to run a numeric iteration at each 
time step. MapleSim simulations will run faster because 
the equations for the overall model are generated once 
and then solved using a very efficient numeric DAE 
solver. 
MapleSim is fully integrated with Maple so users can 
switch between the two environments, depending on the 
task they need to perform. Users can use MapleSim to 



define and simulate the model, and then use Maple to 
visualize and validate the mathematical representation. 
Since the model in this form is fully parameterized, you 
can use it to perform detailed analysis of the system 
such as optimization, sensitivity analysis, validation, 
linearization and simplification, and approximations. 
MapleSim key features will be, see Fig. 16: 

o Click, drag, collapse, expand and connect 
operations that support hierarchical top-down 
and bottom-up development to maximize 
productivity. 

o Seamlessly mix mechanical with, for example, 
electrical, thermal, hydraulic and chemical 
components in one environment. 

o Provides both causal and acausal modelling as 
well as math and code entry in a combined 
single environment to reduce your software 
costs. 

o Unique symbolic technology delivers system 
equations for efficient numeric computation 
and advanced analysis. 

o “As-fast-as-possible” one-shot execution and 
real-time simulation for interactive use. 

o Support for Modelica libraries, and includes 
tools for creating your own component blocks. 

o Remove conversion errors. 
o Export to real-time platforms for HIL testing 

applications. 
o Attach live design documents to your system 

models to minimize rework. 
 

 
 

Figure 16: MapleSim GUI environment 
 

CALIBRATION MODELS 
 
Whenever a need to work with inexact measurements of 
graphical objects occurs, the calibration can be used. It 
is applicable for example in medicine (for location of 
cancer genes), in fotogrammetry (measurements of 
object from airplanes)  and in many other fields. 
Let us assume two random measurement X,Y of one 
object. Then calibration problem is aiming to find a 
function f  so, that Y=f(X). The function f is called 
calibration function. We assume a linear form of 
function f, i.e. Y=a+BX. Matrices a and B are called 
parameters of calibration problem. For more details see 
(Moll and Myšková 2007). 

 
Free calibration 
 
We do not assume any further constraint. The only 
assumption for the calibration model is linearity of 
calibration function. The model is given by 
  

 
 

The estimations of parameters of the model are given by 
 

(1) 
 
 
 
where P is operator of projection. 
 
Calibration of identical non-specified objects 
 
A natural request on calibration function is to retain the 
shape of objects. This leads to request on matrix B to be 
orthonormal. It is used Gauss-Markov model: 
 

 
 
 
       (2) 
 
 
 
 
where 
 
 
 
 

, 
 
 
 
 
and matrix ( )αB  is an orthonormal matrix written in 
some special form. Explicit expressions, for estimation 
of parameters of the model, similar to (1), can be found. 
 
Calibration of identical specified objects - circles 
 
In this case, in addition, we assume that measured 
points lie on circles. Using Gauss-Markov model again, 
very similar to the model (2), it is possible to find 
explicit expressions for estimation of parameters of the 
model. They are similar to (1), but more complex. 
Further details can be found in (Moll and Myšková 
2007). 
 



APPLICATION 
 
Let us consider following two measurements of 2-D 
objects: 

 
Appropriate Maple file (in document mode) for the free 
calibration is shown on Fig. 17. 

 

 
 

Figure 17: Maple document with free calibration 
 
The whole procedure from setting of inputs to 
visualization of results is evidently very simple. Similar 
procedure for the other two types of described 
calibration models can be done. 
Calibration function for free calibration for presented 
data is given by following matrices. 

 

 

Visualization of measurements X and Y and appropriate 
calibrated values are shown on Fig. 18. 
 

 
 

Figure 18: Free calibration 
 
Visualizations of data and appropriate results for 
calibration of identical objects (non-specified and 
circles) are shown on Fig. 19 and Fig. 20. 

 
 

Figure 19: Calibration of identical non-specified objects 
 

 

 
 

Figure 20: Calibration of identical objects - circles 
 

CONCLUSION 
 

http://www.maplesoft.com/applications/app_center_bro
wse.aspx?CID=4&SCID=55 is Maple Web site resource 
for free applications related to mathematical modelling 
and simulations, which obtains 46 applications. There 
are many interested applications and some of them are 
available in translation (French, Spanish, and German). 
The new possibilities offering by the integrated systems 
Maple and MapleSim in modelling and simulation 
technical and scientific problems will enlarge the power 
of Maple technology. A further benefit offers Maple 
toolboxes, which was presented in case of financial 
modelling with two short examples. Three calibration 
models were introduced, including their application 
using the Maple. 
Both Maple and MapleSim will be very useful also for 
students in learning of mathematical modelling. The 
MapleSim technology represents the next generation in 
the modelling and simulations. 
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